CS · EN

Webhosting - Logs

In this article you will learn:


Logging

Using logging, you can uncover the causes of slowdowns or other undesirable website behavior. For the Webhosting service, we offer two types of logs – Accesslog and Errorlog.

Logging starts at the moment the service is launched. Older logs are not available in the system.

Accesslog

Accesslog, or access log, records all access to the website via HTTP and HTTPS. It does not log access via FTP. It is used to monitor general traffic on the website, as well as access to specific files, such as the administration interface.

Errorlog

Errorlog records PHP errors (website scripts) and Apache errors (server). It is mainly useful when testing website updates (for example plugins), or when identifying possible causes of Error 503.


Activating logging

If you need to obtain logs for WMS webhosting, skip this step and continue with the Obtaining logs section. WMS webhostings always have logging enabled.

For regular Webhosting, Accesslog and Errorlog are add-on services. You can activate them with these steps:

  1. Log in to the customer administration ⧉.
  2. In the top menu, select Hosting services Webhosting.
  3. From the menu, select the webhosting for which you want to enable logging.
  4. In the left menu, select Add-on services.
  5. For the selected service, click the + button on the left side of the table.
  6. If you want to activate the logs only temporarily (free for 24 hours), check the activate temporarily for 24 hours box.
  7. Click the Activate button.
Activation of the Accesslog and Errorlog extensions in the customer administration
Activation of the Accesslog and Errorlog extensions in the customer administration

Activating the logs starts the logging process. The setting will take effect within 30 minutes. Events (accesses, errors) that occurred before the service was started will not be available in the logs.

Temporary activation (free for 24 hours) can only be performed once every 30 days.


Obtaining logs

WMS service logs are temporarily unavailable. Regarding their delivery, contact customer support ⧉.

The system stores both Accesslogs and Errorlogs in a new file every day. In the full version, you can download logs up to 7 days old (but not older than the start of the add-on service). In the limited version (24 hours free), only logs for the given time period are available).

You can obtain log outputs directly in the customer administration. Follow these steps:

  1. Log in to the customer administration.
  2. In the top menu, select Hosting services Webhosting.
  3. From the menu, select the webhosting from which you want to obtain log data.
  4. In the left menu, select Logs.
  5. For the log type and date whose log you want to obtain, click the obtain log button.
  6. After the log is generated, click the download log button.

You can view downloaded CSV logs, for example, in a spreadsheet application (Excel, Calc, and similar).

Log handling in the customer administration
Log handling in the customer administration

Frequently asked questions

How do I find out who connected to my webhosting via FTP, when, and from where?

Unfortunately, we do not log FTP access.

The error occurred before I turned on logging. How do I access older logs?

The service does not provide logs older than the start of logging. If you need to log for a longer period than 24 hours, activate the service permanently.

Why is my log empty?

It usually takes up to half an hour for the service to start in the system. If you generate the log immediately after activation in the customer administration, it will be empty.

Can I download logs automatically?

Unfortunately, we do not currently support automatic generation and downloading of logs.